Cacti (home)ForumsDocumentation

Differences

This shows you the differences between two versions of the page.

userplugin:autom8thold [2013/10/29 07:10] (current)
Hipska created
Line 1: Line 1:
 +====== Autom8-Thold ======
  
 +---- dataentry plugin_style ----
 +type:userplugin
 +userplugin_nspage:autom8thold
 +author_page:wiki:user:Hipska
 +description:Automate threshold creation for data sources
 +version:1.0
 +pia_version:3.1
 +cacti_version:0.8.8a
 +homepage_url:https://github.com/Super-Visions/cacti-plugin-autom8thold
 +date: 2013-10-29
 +plugins_tags: automation, threshold, autom8, thold
 +----
 +===== Download =====
 +
 +This plugin can be download here: [[https://github.com/Super-Visions/cacti-plugin-autom8thold/releases|GitHub Releases]]
 +
 +===== Purpose =====
 +
 +This plugin allows to create rules similar to Autom8 Graph - and Tree Rules to specify which thresholds need to be added to data sources.
 +
 +===== Features =====
 +
 +  * Define Rules based on existing Data Queries
 +  * Preview of matching Hosts and Data Sources
 +  * Rules are executed when a new graph has been created
 +
 +===== Prerequisites =====
 +
 +This plugin requires the Autom8 plugin to be installed and activated. The Thold plugin, of which the versions 0.4.9 and 0.5.0 are compatible, needs to be installed too. 
 +This plugin is tested with Cacti 0.8.8a and PIA 3.1 but it should also work on older versions. 
 +This plugin contains patches for Autom8 v0.35, older versions of the plugin will need different patches and might not work with this plugin.
 +
 +===== Installation =====
 +
 +  - Untar contents to the Cacti plugins directory
 +  - Apply following [[userplugin:autom8thold#patches]]
 +  - Install and Activate from Cacti UI
 +
 +===== Patches =====
 +
 +In order to get this plugin running, applying patches to the plugin Autom8 is required.
 +
 +Run following command from plugins directory:
 +<code bash>
 +patch --dry-run -d autom8/ < autom8thold/autom8_v035.patch
 +</code>
 +If everything looks ok, you can omit the %%--dry-run%% option and run the command again to actually do the patches.
 +**Note:**  The patch autom8_v035.patch might warn you about reverting patches if you have done this patch already for the plugin [[userplugin:autom8reportit]]. In this case, you can ignore this patch as it is already done.
 +
 +===== Usage =====
 +
 +===== Additional Help? =====
 +
 +If you need additional help, please go to
 +
 +===== Possible Bugs? =====
 +
 +===== Screenshots =====
 +
 +[[plugin:autom8thold.screenshots]]





Personal Tools