Cacti (home)ForumsDocumentation

Using Graphs Tab

This Chapter shows how to use the Graph tab to view your results.

The Tree Mode

The start page of cacti show two blue tabs, when logging in with admin permissions, the Console and the Graphs. Users without special permissions will see the latter one only.

Start Page

If you click the Graphs tab right after generating some graph, you won't see anything yet. So lets fill it first. This can be done from the Devices page, when using cacti 0.8.6h. Select your device by entering a Search pattern. Then, please select the checkbox to the right. From the Choose an Action dropdown, select Place on a Tree (Default Tree) to see:

Add Tree Item from Devices List

Now click Go to see:

Confirm adding a new Tree Item

Accept this by selecting Yes and you're done. Now lets look at the results by selecting the blue Graphs Tab. You'll have to select your Device, my own routing device in this case.

Graphs Tree View

Notice the four new Tabs to the right, one of them, the Graphs Tree Tab, being display all in red. One other thing to pay attention to is the little magnifying glass next to each graph. We'll explain this in a minute.

You will have noticed, that this view displays all currently defined graphs for this host. In fact, as soon as you add more graphs to this host, they will automagically show up in this view. In this case, we've added the whole Host to the Graph Tree, but there are other options as well.

But first, please select the Graph itself by clicking anywhere on it. Now you'll see (by default) four new graphs. Each of them showing a different timespan, from Daily to Yearly. The next image show the two topmost of them:

Graphs with all RRAs displayed

Now to the magnifying glass. You've seen in in the previous graph, and now in again appears next to each of the four graphs. Lets click to see:

Graph Zoom Function

The little red square was drawn by placing the cursor at one corner and dragging it to the diagonally placed corner. Thus you define the area to be magnified. In this case, only the x-axis takes effect. You'll see: Graph Zoom Function in Action

That's nice, eh?

Creating a Graph Tree

To create a new graph tree, select the Graph Trees menu item under the Management header. Select Add on this page to create a new tree. The following page will prompt you for a tree name, which will be used to identify the graph tree throughout Cacti. Along with the Name, you may select one of four currently supported Sorting Types

Table 8-1. Tree Sporting Type Definitions

FieldDescription
NameName of the tree entry. The sort order of all trees themselves is always alphabetical
Sorting Type
  • Manual Ordering (No Sorting): You may chance the sequence at your will
  • Alphabetical Ordering: All subtrees are ordered alphabetically, unless specifies otherwise (you may chance sort options at subtree lebel), i.e. 1, Ab, ab
  • Natural Ordering: ie. ab1, ab2, ab7, ab10, ab20
  • Numeric Ordering: Leading zeroes are not taken into account when ordering numerically, i.e. 01, 02, 4, 04

Once you type a name, click the Create button to continue. You will be redirected to a page similar to the one below, but without all of the items.

Editing a Graph Tree

To start adding items to your tree, click add in the Tree Items box. There are currently three different types of tree items you can choose from: header, graph, or host. Simply choose the type you want, fill in the value for that type, and click Create to make your new graph tree item. Clicking the Add link to the right of any branch will add the new item below that branch, you can change the branch that any item belongs to by changing its Parent Item field.

Please note the ++ and the -- buttons. They will help you managing large trees. Pressing the -- will collapse all tree levels while ++ expands all of them. You may expand each single subtree of a collapsed tree to reorder, add or delete entries without much scrolling.

The List Mode

Now lets turn to the next Graphs View Mode, the List View:

The List View

The is the second to last tab on the right side. Find the Filter by Host accompanied by an additional text field that allows for freetext filtering. I've selected the will know router to find all three recently defined Graphs. From the Headings, you may learn how many Graphs are in the result set after filtering. There may be more than one page.

Now, I've selected the first and the third row. Selecting View yields following result:

List View Selected

The display now shows both graphs side-to-side. Notice, that the Legends are suppressed. The layout is defined by the user-specific values to be found under the Settings Tab. You may play with those values to design the layout to your likings.

Please also notice, that the Tab changed from List View to Preview Mode automatically. To get more details of a specific view, you may again click on one of the graphs to see:

List View Selected with all RRAs

The Magnifying Glass works as described above.

The Preview Mode

You've already had a short glance at this mode in the previous chapter. When selecting the rightmost tab you're presented with a list of all existing graphs, divided up into several pages. You may scroll to Next or Previous pages.

Preview Mode - Unfiltered

Lets have a look at all those filtering capabilities. Most of those will hold for other lists as well. Lets start with the explicit selection of a host via Filter by Host:

Preview Mode - Host Filter

Notice the text field to the right to the Filter by Host. Text entered here will be searched in all existing Graph Titles:

Preview Mode - Title Filter

Be aware of the fact, that this text shows up in an SQL SELECT clause. If you remember your SQL skills, the percent (%) sign is used to make up partly qualified SQL SELECT clauses (wildcard). So look at the next image

Preview Mode - Filter using wildcard

It is possible to use the underscore (_) for wildcarding a single character.






Personal Tools